Back to overview
Maintenance
Trading Systems Maintenance
Jan 05 at 04:00pm UTC
–
Jan 05 at 04:31pm UTC
Affected services
Trading Engine
Exchange Data Services
Account Data Services
Resolved
Jan 05 at 04:31pm UTC
Maintenance has ended early. You may resume normal trading.
Affected services
Created
Jan 05 at 04:00pm UTC
Bluefin Pro will be receiving routine upgrades and will have intermittent availability during the maintenance window.
Affected services