Back to overview
Degraded

Increased Latency for Trading Systems

Apr 23, 2026 at 7:17pm UTC
Affected services
Trading Engine

Resolved
Apr 23, 2026 at 8:58pm UTC

Latencies have stabilized. We will continue to monitor, but consider the incident resolved.

Updated
Apr 23, 2026 at 7:43pm UTC

Latencies have improved, but are not fully stabilized yet. We will perform a follow up release shortly to mitigate further.

Updated
Apr 23, 2026 at 7:20pm UTC

We have identified a likely cause and are preparing for a release to fix it.
A brief downtime will occur for the release.

Created
Apr 23, 2026 at 7:17pm UTC

We're observing an increase in end-to-end latencies for our trading system.