Back to overview
Degraded
Pro Withdrawals Delayed
May 5, 2026 at 1:39pm UTC
Affected services
Trading Engine
Resolved
May 5, 2026 at 2:57pm UTC
All lag has cleared and we are processing withdrawals in real-time again.
Affected services
Created
May 5, 2026 at 1:39pm UTC
Due to congestion in our synchronization to Sui, withdraws are currently delayed. Root cause is understood and we're working on resolving.
Affected services