Back to overview
Degraded
Pro Withdrawals Delayed
May 15, 2026 at 4:53am UTC
Affected services
Trading Engine
Resolved
May 15, 2026 at 7:08am UTC
All withdrawals have been processed and are processing in real time again.
Affected services
Created
May 15, 2026 at 4:53am UTC
Due to congestion in our synchronization to Sui, withdrawals are temporarily delayed. We are working to unblock them.
Affected services