Back to overview
Resolved

Perpetuals trading is temporarily unavailable

Jun 29, 2026 at 9:37pm UTC
Affected services
Trading Engine
Exchange Data Services
Account Data Services

Resolved
Jun 29, 2026 at 9:54pm UTC

We have resolved the issue

Created
Jun 29, 2026 at 9:37pm UTC

Perpetuals trading is currently unavailable. We are actively working on fixing the issue.